Skip to content

兼容性构建

为了让深度迁移更容易,我们提供了一个兼容版本,对相对于 v0.x 版本中的破坏性更改进行了修整。你可以用它来替代 shiki 并逐步迁移。

安装

NPM versionNPM downloadsGitHub

package.json 中为 shiki 设置别名:

json
{
  "dependencies": {
    "shiki": "0.14.3",
    "shiki": "npm:@shikijs/compat@1.0"
  }
}

你也可以查看 破坏性改动列表 以助于你手动迁移这些更改。

以 MIT 许可证发布